Hallo, ich bin neu hier und nicht super erfahren mit Ubuntu. Ich habe folgendes Problem: Nach alt update und alt upgrade erhalte ich stets die Meldung, das 16 Upgrades von PHP 8.5 zurückgehalten werden.
Was muss ich tun, damit die Abhängigkeiten wieder stimmen?
LG Jonas
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 | upgrade php8.5-common Calculating upgrade... Error! Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: Unsatisfied dependencies: php8.5-bcmath : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-bz2 : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-cli : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-curl : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-fpm : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-gd : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-gmp : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-intl : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-ldap : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-mbstring : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-mysql : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-readline : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-sqlite3 : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-xml : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed php8.5-zip : Depends: php8.5-common (= 8.5.4-0ubuntu1) but 8.5.4-0ubuntu1.1 is to be installed Error: Unable to satisfy dependencies. Reached two conflicting assignments: 1. php8.5-common:amd64=8.5.4-0ubuntu1 is selected for install because: 1. php8.5-ldap:amd64=8.5.4-0ubuntu1 is selected for install 2. php8.5-ldap:amd64=8.5.4-0ubuntu1 Depends php8.5-common (= 8.5.4-0ubuntu1) 2. php8.5-common:amd64=8.5.4-0ubuntu1 is not selected for install because: 1. php8.5-common:amd64=8.5.4-0ubuntu1.1 is selected as an upgrade 2. php8.5-common:amd64=8.5.4-0ubuntu1.1 conflicts with other versions of itself apt upgrade php8.5-bcmath Calculating upgrade... Error! Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: Unsatisfied dependencies: php8.5-bcmath : Depends: php8.5-common (= 8.5.4-0ubuntu1.1) but 8.5.4-0ubuntu1 is to be installed Error: Unable to satisfy dependencies. Reached two conflicting assignments: 1. php8.5-common:amd64=8.5.4-0ubuntu1.1 is selected as an upgrade because: 1. php8.5-bcmath:amd64=8.5.4-0ubuntu1.1 is selected as an upgrade 2. php8.5-bcmath:amd64=8.5.4-0ubuntu1.1 Depends php8.5-common (= 8.5.4-0ubuntu1.1) 2. php8.5-common:amd64=8.5.4-0ubuntu1.1 is not selected for install because: 1. php8.5-common:amd64=8.5.4-0ubuntu1 is selected for install 2. php8.5-common:amd64=8.5.4-0ubuntu1.1 conflicts with other versions of itself |
Bearbeitet von sh4711:
Bitte verwende in Zukunft Codeblöcke, um die Übersicht im Forum zu verbessern!
Moderiert von Thomas_Do:
Kein Spam.